hdu 1159 滚动数组+LCS

Palindrome

 

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意:给出字符串,可任意添加字符,问最少添多少字符能使其变成回文字符串。

题解1:LCS,dp[i][j]代表从i到j需要添加的最小个数。开dp[5050][5050]会超内存,所以用滚动数组,dp[2][5050].

滚动数组可以极大的节省内存,不影响时间复杂度,dp是自下而上的过程,dp[i][j]=min(dp[i],[j-1],dp[i-1][j]), 也就是只用最近的两个解, dp[i%2][j],省去了前面无用的解。

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main(){
	int n,i,j;
	char s[5050];
	int dp[2][5050];
	while (scanf ("%d",&n)!=EOF){
		getchar();
		memset(dp,0,sizeof(dp));
		memset(s,0,sizeof(s));
		scanf ("%s",s);
		for (i=n-2;i>=0;i--){//降序
			for (j=i+1;j<n;j++){//升序
				if (s[i]==s[j])//不需要添加字符
				dp[i%2][j]=dp[(i+1)%2][j-1];
				else
				dp[i%2][j]=min(dp[i%2][j-1],dp[(i+1)%2][j])+1;
			}
		}
		printf ("%d\n",dp[0][n-1]);
	}
	return 0;
} </span>

题解2:(容易理解)设立一个数组逆序排列,然后求出二者的LCS,长度-LCS即为所求。


<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,i,j;
char s[5050];
char a[5050];
int dp[2][5050];
int main()
{
    
	while(scanf("%d",&n)!=EOF)
	{
	    getchar();
		scanf("%s",&s);
		memset(dp,0,sizeof(dp));
		int k=0;
		for(i=0;i<n;i++)
		a[n-i-1]=s[i];//逆序
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(s[i-1]==a[j-1]) dp[i%2][j]=dp[(i-1)%2][j-1]+1;
				else{
					dp[i%2][j]=max(dp[i%2][j-1],dp[(i-1)%2][j]);
				}
			}
		}
		printf("%d\n",n-dp[n%2][n]);
	}
	return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值