水 原题
Description
在三维空间里,晴天得到了一些坐标,然后他想知道这些坐标有没有重合的哇,然后若两个坐标是重合的也就是x=x,y=y,z=z。然后他把这个任务交给你啦。
Input
输入第一行包含一个整数t表示有多少组数据。
每组数据一个整数n,表示有多少个点。
接下来n行,每行有三个整数x,y,z表示一个点的坐标.
0<=n<=200000,0<=x,y,z<100,t<=20
Output
若有两个点重合输出yes,否则输出no
Sample Input
1
3
1 1 1
1 2 1
1 1 1
Sample Output
yes
题意:问三维坐标是否有重合。
</pre><pre name="code" class="cpp"><span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
#define M 110
using namespace std;
int vis[M][M][M];
int main(){
int t,n;
int x,y,z;
int flag;
int i;
scanf ("%d",&t);
while (t--){
flag=0;
memset (vis,0,sizeof(vis));
scanf ("%d",&n);
for (i=1;i<=n;i++){
scanf ("%d %d %d",&x,&y,&z);
if (vis[x][y][z]==1)
flag=1;
vis[x][y][z]=1;
}
if (flag)
printf ("yes\n");
else
printf("no\n");
}
return 0;
} </span>