Lightoj 1045 (Digits of factoria)

   数学 Digits of factoria

Description

Factorial of an integer is defined by the following function

f(0) = 1

f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input

Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output

For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input

5

5 10

8 10

22 3

1000000 2

0 100

Sample Output

Case 1: 3

Case 2: 5

Case 3: 45

Case 4: 18488885

Case 5: 1

  题意:求k进制下n!的位数

题解:n!的位数为log10(n!) , k进制则为logk(n!) , log(n!)=log(1*2*3*.....*n)=log(1) + log(2) + ....+log(n)

   换底公式:logk(n!)=lg(n!)/lg(k) ,所以s=lg(n!)/lg(k)+1。

#include<cstdio>
#include<cmath>
#define M 1000006
using namespace std;
	double lo[M-1];
int main(){
	int t,n,b, i,cas=1;

	int ans;
	scanf ("%d",&t);
	for (i=1;i<M;i++){
		lo[i]=lo[i-1]+log(i);
	}
	while (t--){
		scanf ("%d %d",&n,&b);
		ans=int(lo[n]/log(b))+1;
		printf ("Case %d: %d\n",cas++,ans);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值