数的直径 poj1383(Labyrinth)

Labyrinth

 

Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

题意:求最长路,树的直径模板题,利用两次BFS。第一次找出最长路的端点,第二次求距离。

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int t,c,row;
char map[1010][1010];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
int vis[1010][1010];
int s,maxi;
int tx,ty,ans;
struct node{
	int u,v,s;
}r,now; 
int judge(int x,int y){
	if (!vis[x][y]&&x<=row &&x>=1 &&y<=c&&y>0 && map[x][y]!='#')
	return 1;
	return 0;
}
void bfs(int x,int y){
	memset (vis,0,sizeof(vis));
	queue<node> q;
	r.u=x,r.v=y,r.s=0;
	q.push(r);
	ans=0;
	while (!q.empty()){
		r=q.front();
		q.pop();
		for (int i=0;i<4;i++){
			now.u =r.u+dx[i];
			now.v =r.v+dy[i];
			now.s =r.s+1;
			if (judge(now.u,now.v)){
				vis[now.u][now.v]=1;
				if (ans<now.s){//更新直径
					ans=now.s;
					tx=now.u;
					ty=now.v;
				}
				q.push(now);
			}
		}
	}
	
}
int main(){
	int i,j,sx,sy;
	scanf ("%d",&t);
	while (t--){
		scanf ("%d %d",&c,&row);
		int flag=0;
		for (i=1;i<=row;i++){
			scanf ("%s",map[i]);
			if (flag) continue;
			for (j=1;j<=c;j++){
				if (map[i][j]=='.'){
					sx=i,sy=j;
					flag=1;
				}
			}
		}
		bfs(sx,sy);
		bfs(tx,ty);
		printf ("Maximum rope length is %d.\n",ans);
	}
	return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值