Sicily 2404. Queen Collision

2404. Queen Collision

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

no collisions
 

5x5 4 collisions
 

size 8, 5 collisions
 

Figure 1Figure 2Figure 3
 


Lots of time has been spent by computer science students dealing with queens on a chess board.  Two queens on a chessboard collide if they lie on the same row, column or diagonal, and there is no piece between them.  Various sized square boards and numbers of queens are considered.  For example, Figure 1, with a 7 x 7 board, contains 7 queens with no collisions.  In Figure 2 there is a 5 x 5 board with 5 queens and 4 collisions.  In Figure 3, a traditional 8 x 8 board, there are 7 queens and 5 collisions. 

On an n x n board, queen positions are given in Cartesian coordinates (xy)  where x is a column number, 1 to n, and y is a row number, 1 to n.  Queens at distinct positions (x1, y1) and (x2, y2) lie on the same diagonal if (x1- x2) and (y1- y2) have the same magnitude.  They lie on the same row or column if x1= x2 or y1= y2, respectively.  In each of these cases the queens have a collision if there is no other queen directly between them on the same diagonal, row, or column, respectively.  For example, in Figure 2, the collisions are between the queens at (5, 1) and (4, 2), (4, 2) and  (3, 3), (3, 3) and (2, 4), and  finally (2, 4) and (1, 5).  In Figure 3, the collisions are between the queens at (1, 8) and (4, 8), (4, 8) and (4, 7), (4, 7) and (6, 5),  (7, 6) and (6, 5), and  finally (6, 5) and (2, 1).  Your task is to count queen collisions.
 

In many situations there are a number of queens in a regular pattern. For instance in Figure 1 there are 4 queens in a line at (1,1), (2, 3), (3, 5), and (4, 7).  Each of these queens after the first at (1, 1) is one to the right and 2 up from the previous one.  Three queens starting at (5, 2) follow a similar pattern.  Noting these patterns can allow the positions of a large number of queens to be stated succinctly.

 

Input

The input will consist of one to twenty data sets, followed by a line containing only 0.
The first line of a dataset contains blank separated positive integers  n g, where  n indicates an  n x  n board size, and  g is the number of linear patterns of queens to be described, where  n  < 30000, and  g < 250.  The next  g lines each contain five blank separated integers,  k x y s t, representing a linear pattern of  k queens at locations ( x +  i* sy + i* t), for  i = 0, 1, ...,  k-1.  The value of  k is positive.  If  k is 1, then the values of s and t are irrelevant, and they will be given as 0.  All queen positions will be on the board.  The total number of queen positions among all the linear patterns will be no more than  n, and all these queen positions will be distinct.

Output

There is one line of output for each data set, containing only the number of collisions between the queens.
The sample input data set corresponds to the configuration in the Figures.  
 
Take some care with your algorithm, or else your solution may take too long.

Sample Input

7 2
4 1 1 1 2
3 5 2 1 2
5 1
5 5 1 -1 1
8 3
1 2 1 0 0
3 1 8 3 -1
3 4 8 2 -3
0

Sample Output

0
4
5

Problem Source

每周一赛第四场

// Problem#: 2404
// Submission#: 3590815
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>

unsigned short r[30005], c[30005], d[60005], b[60005];

int main() {
    int n, m, k, x, y, s, t, tx, ty;
    while (scanf("%d", &n) && n) {
        scanf("%d", &m);
        while (m--) {
            scanf("%d%d%d%d%d", &k, &x, &y, &s, &t);
            for (int i = 0; i < k; i++) {
                tx = x + i * s;
                ty = y + i * t;
                r[tx]++;
                c[ty]++;
                d[tx + ty]++;
                b[tx - ty + n]++;
            }
        }
        int size = n, ans = 0;
        for (int i = 1; i <= size; i++) {
            if (r[i] > 1) ans += r[i] - 1;
            if (c[i] > 1) ans += c[i] - 1;
            r[i] = c[i] = 0;
        }
        size = 2 * n;
        for (int i = 1; i < size; i++) {
            if (b[i] > 1) ans += b[i] - 1;
            if (d[i] > 1) ans += d[i] - 1;
            d[i] = b[i] = 0;
        }
        printf("%d\n", ans);
    }
    return 0;
}                                 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值