Sicily 1861. Counting quadrangles

1861. Counting quadrangles

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

Seen from the graphs above,you should have found that the graph becomes more complex when n increases.How many quadrangles are there in the square?It’s not so easy to answer,Have a think. 

Input

The first line of the input is a positive integer which represents the number of the test cases followed.Each test case contains a positive integer n (n<= 100).

Output

The output of the program should consist of one line of output for each test case. The output of each test case only contains the number of the quadrangles in the square whose length is n.No any redundant spaces are needed. 

Sample Input

2
1
2

Sample Output

1

23

// Problem#: 1861
// Submission#: 3590245
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <string.h>

const int MAXN = 101;

int solve(int n) {
    int ret = 0, i, num1, num2, num3;
    num1 = n * n * (n + 1) * (n + 1) / 4;
    ret += num1;
    num2 = 0;
    for (i = 1; i <= n; i++) num2 += i * i;
    num3 = num1 - num2;
    ret += 3 * num3;
    for (i = 2; i <= n; i++) ret += (i - 1) * 2 * (n + 1 - i) * (n + 1 - i);
    return ret;
}

int main() {
    int n, tn;
    scanf("%d", &tn);
    while (tn--) {
        scanf("%d", &n);
        printf("%d\n", solve(n));
    }
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值