Sicily 1902. Counting Problem

1902. Counting Problem

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Yes. Counting problem comes again. 
Given a chess board of N*N (N<=500), how many ways are there to put N queens on it so that no queen can attack another? 
Luckily this is not the problem you should solve in this contest. Instead, we have a much easier one here.
Given a chess board of N*N (N<=500), how many ways are there to put 2*N queens on it so that there are exactly two queens in each row and each column?
To make it even easier, we will consider one way to be the same with another if it can be transformed to the other one by swapping rows and swapping columns. 

Input

The first line of the input is an integer T indicating the number of cases. 
Line 2..T+1 will contain an positive integer N (N <=500) each. 

Output

T lines containing your counting results respectively.
For the number may be very large, you just have to output its module by 1000007. 

Sample Input

3
2
5
4

Sample Output

1
2

2

// Problem#: 1902
// Submission#: 3590628
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <string.h>

const int MAXN = 500;
const int M = 1000007;

int a[MAXN + 1];

void init() {
    memset(a, 0, sizeof(a));
    a[0] = 1;
    for (int i = 2; i <= MAXN; i++) {
        for (int j = i; j <= MAXN; j++) {
            a[j] += a[j - i];
            if (a[j] >= M) a[j] -= M;
        }
    }
}

int main() {
    init();
    int cs, n;
    scanf("%d", &cs);
    while (cs--) {
        scanf("%d", &n);
        printf("%d\n", a[n]);
    }
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值