Sicily 13296. Kingdom Rush II

13296. Kingdom Rush II

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

 

Like the last time, the path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i (L<=i<=R). Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

 

However, this time a witch helps your enemies and makes every monster has its own place of appearance (block Xi). Monsters still go straightly to block N.

 

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0, it will die and disappear.

 

Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.

Input

The first line of the input is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of block the ith monster appears.

Output

Output one line containing the number of surviving monsters.

Sample Input

521 3 15 5 251 33 15 27 39 1

Sample Output

3

Hint

 In the sample, three monsters with origin HP 5, 7 and 9 will survive.

Problem Source

"6CIT杯"第五届中山大学ICPC新手赛 by 蒙澎权

// Problem#: 13296
// Submission#: 3560831
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>

long long da[100005];

int main() {

    long long N, M, K, st, ed, d, ans = 0, sum = 0;
    scanf("%lld%lld", &N, &M);
    while (M--) {
        scanf("%lld%lld%lld", &st, &ed, &d);
        da[st] += d;
        da[ed + 1] -= d;
    }
    for (int i = 1; i <= N; i++) da[i] = sum += da[i];
    for (int i = N - 1; i >= 1; i--) da[i] += da[i + 1];
    scanf("%lld", &K);
    while (K--) {
        scanf("%lld%lld", &d, &st);
        if (d > da[st]) ans++;
    }
    printf("%lld\n", ans);

    return 0;
}                                 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值