hdu4970 Killing Monsters 树状数组 区间修改

Killing Monsters

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2843    Accepted Submission(s): 1070


Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.
 

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.
 

Output
Output one line containing the number of surviving monsters.
 

Sample Input
 
 
5 2 1 3 1 5 5 2 5 1 3 3 1 5 2 7 3 9 1 0
 

Sample Output
 
 
3
Hint
In the sample, three monsters with origin HP 5, 7 and 9 will survive.
 


原来的值存在a[]里面,多建立个数组c1[],注意:c1[i]=a[i]-a[i-1]。

  那么求a[i]的值的时候a[i]=a[i-1]+c1[i]=a[i-2]+c1[i]+c1[i-1]=…..=c1[1]+c1[2]+…+c1[i]。

  所以就用c1[]建立树状数组,便可以很快查询a[i]的值。

getSum(i)表示c[i]的前缀和,即a[i]的值
再倒序循环令a[i] = a[i+1] + getSum(i);

之后a[i]的值表示i到n所有格子的攻击和,即为怪物从i点出发到n所受总伤害

#include <bits/stdc++.h>
using namespace std;
const int N = 100005;
int c[N];//c[i]表示格子i和格子i-1的攻击差,对c[i]进行getsum(i)即可得到格子i的攻击值
long long a[N];
int n,m,k;
int lowbit(int x){return x & (-x);}

void add(int x,int w){
    for (int i = x;i <= n;i += lowbit(i)){
        c[i] += w;
    }
}

long long getSum(int x){
    long long sum = 0;
    for (int i = x;i > 0;i -= lowbit(i)){
        sum += c[i];
    }
    return sum;
}

int main(){
    while(~scanf("%d",&n) && n){
        scanf("%d",&m);
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for (int i = 0;i < m;i++){
            int l,r,w;
            scanf("%d%d%d",&l,&r,&w);
            add(l,w);
            add(r+1,-w);
        }
        a[n+1] = 0;
        for (int i = n;i >= 1;i--) a[i] = a[i+1] + getSum(i);
        scanf("%d",&k);
        int ans = 0;
        for (int i = 0;i < k;i++){
            long long hi,pos;
            scanf("%lld%lld",&hi,&pos);
            //cin >> hi >> pos;
            if (a[pos] < hi) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

原来的值存在a[]里面,多建立个数组c1[],注意:c1[i]=a[i]-a[i-1]。

  那么求a[i]的值的时候a[i]=a[i-1]+c1[i]=a[i-2]+c1[i]+c1[i-1]=…..=c1[1]+c1[2]+…+c1[i]。

  所以就用c1[]建立树状数组,便可以很快查询a[i]的值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值