Sicily 1729. Steganography

1729. Steganography

Constraints

Time Limit: 5 secs, Memory Limit: 32 MB

Description

In cryptography, the goal is to encrypt a message so that, even if the the message is intercepted, only the intended recipient can decrypt it. In steganography, which literally means "hidden writing", the goal is to hide the fact that a message has even been sent. It has been in use since 440 BC. Historical methods of steganography include invisible inks and tatooing messages on messengers where they can't easily be seen. A modern method is to encode a message using the least-significant bits of the RGB color values of pixels in a digital image.

For this problem you will uncover messages hidden in plain text. The spaces within the text encode bits; an odd number of consecutive spaces encodes a 0 and an even number of consecutive spaces encodes a 1. The four texts in the example input below (terminated by asterisks) encode the following bit strings: 11111, 000010001101101, 01, and 000100010100010011111. Each group of five consecutive bits represents a binary number in the range 0–31, which is converted to a character according to the table below. If the last group contains fewer than five bits, it is padded on the right with 0's.

" " (space)0
"A" – "Z"1–26
"'" (apostrophe)27
"," (comma)28
"-" (hyphen)29
"." (period)30
"?" (question mark)31

The first message is 111112 = 3110 = "?". The second message is (00001, 00011, 01101)2 = (1, 3, 13)10 = "ACM". The third message is 010002 = 810 = "H", where the underlined 0's are padding bits. The fourth message is (00010, 00101, 00010, 01111, 10000)2 = (2, 5, 2, 15, 16)10 = "BEBOP".

Input

The input consists of one or more texts. Each text contains one or more lines, each of length at most 80 characters, followed by a line containing only "*" (an asterisk) that signals the end of the text. A line containing only "#" signals the end of the input. In addition to spaces, text lines may contain any ASCII letters, digits, or punctuation, except for "*" and "#", which are used only as sentinels.

Output

For each input text, output the hidden message on a line by itself. Hidden messages will be 1–64 characters long.

Note: Input text lines and output message lines conform to all of the whitespace rules listed in item 7 of Notes to Teams except that there may be consecutive spaceswithin a line. There will be no spaces at the beginning or end of a line.

Sample Input

Programmer,
I  would  like  to  see
a  question
mark.
*
Behold, there is more to  me than you might
think  when  you read  me  the first  time.
*
Symbol   for    hydrogen?
*
A B C D  E F G H  I J  K L M N  O P Q  R  S  T  U  V
*
# 

Sample Output

?
ACM
H

BEBOP

// Problem#: 1729
// Submission#: 3325430
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <vector>
#include <iomanip>
#include <map>
#include <stack>
#include <functional>
#include <list>
#include <cmath>
using namespace std;

vector<int> v;
string temp;
char t[33] = " ABCDEFGHIJKLMNOPQRSTUVWXYZ',-.?";

void cal() {
    int s = temp.size();
    for (int i = 0; i < s; ) {
        if (temp[i] == ' ') {
            int counter = 1, j;
            for (j = i + 1; j < s && temp[j] == ' '; j++) counter++;
            v.push_back((counter + 1) % 2);
            i = j;
        } else i++;
    }
}

void solve() {
    int s = (v.size() / 5 + (v.size() % 5 ? 1 : 0)) * 5;
    int os = v.size();
    for (int i = os; i < s; i++) v.push_back(0);
    vector<int> text;
    int sum = 0;
    for (int i = 0; i < v.size(); i++) {
        if (i % 5 == 0) sum = 0;
        sum = sum * 2 + v[i];
        if ((i + 1) % 5 == 0) cout << t[sum];
    }
    cout << endl;
    v.clear();
}

int main() {

    std::ios::sync_with_stdio(false);

    while (1) {
        getline(cin, temp);
        if (temp == "*") solve();
        else if (temp == "#") break;
        else cal();
    }

    

    //getchar();
    //getchar();
    
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值