Sicily 1121. Tri Tiling

1121. Tri Tiling

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes?

Here is a sample tiling of a 3x12 rectangle.

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input

2
8
12
-1

Sample Output

3
153

2131

// Problem#: 1121
// Submission#: 3288659
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <iostream>
#include <vector>
#include <string>
#include <stack>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <functional>
using namespace std;

int ans[31];

int main() {

    std::ios::sync_with_stdio(false);

    
    ans[0] = 1;
    ans[2] = 3;
    for (int i = 4; i <= 30; i += 2) {
        ans[i] = 3 * ans[i - 2];
        for (int j = i - 4; j >= 0; j -= 2) {
            ans[i] += 2 * ans[j];
        }
    }

    while (1) {
        int temp;
        cin >> temp;
        if (temp == -1) break;
        cout << ans[temp] << endl;
    }

    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值