1121 Damn Single (25 point(s))

1121 Damn Single (25 point(s))

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

哈希、STL。

首先建立哈希表,假设每一个在场的人都是单身;然后遍历所有的夫妻数对,如果它们都在场,则说明他们不会孤独,于是取消标记、在场单身人数减2。

#include<iostream>
#include<cstring>
#include<vector> 
using namespace std;
vector<pair<int,int> > v;
const int MAX = 1e5+7;
bool mark[MAX]={false};
int main(void){
	int N,M,a,b;cin>>N;
	while(N--){
		cin>>a>>b;
		v.push_back(pair<int,int>(a,b));
	}
	cin>>M;
	for(int i=0;i<M;i++){
		cin>>a;mark[a]=true;
	}
	for(auto i :v){
		if(mark[i.first]&&mark[i.second]){
			M-=2;
			mark[i.first]=false;
			mark[i.second]=false;
		}
	}
	bool flag = false;cout<<M<<endl;
	for(int i=0;i<100001;i++){
		if(mark[i]){
			if(!flag) printf("%05d",i),flag=true;
			else printf(" %05d",i);
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值