2014ACM集训13级PK赛2-Guess the Price

Description

In the television program "Shopping Street" of CCTV-2, two people, A and B are guessing price of a given item. You are asked to decide whose price is closer to the real price.

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains three integers in one line: PPAPB (0 <= PAPB <= P <= 100, PA != PB), indicating the real price, the price A guesses and the price B guesses.

Output

For each case, output "A" or "B" according to whose price is closer to the real price.

Sample Input

3
10 8 7
20 20 19
100 9 50

Sample Output

AAB

 

#include <stdio.h>
#include <math.h>
#include <stdlib.h>

int pd (int pa,int a,int b)
{
    int ca = fabs(pa - a);
    int cb = fabs(pa - b);
    if (ca > cb)
        return 0;
    else
        return 1;
}

int main()
{
    int N;
    scanf ("%d",&N);

    while (N--)
    {
        int pa,a,b;
        scanf ("%d%d%d",&pa,&a,&b);

        int tf = pd (pa,a,b);

        if (tf)
            puts ("A");
        else
            puts ("B");
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值