ZOJ 3333 Guess the price

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3758


题面:


Guess the Price

Time Limit: 1 Second       Memory Limit: 32768 KB

In the television program "Shopping Street" of CCTV-2, two people, A and B are guessing price of a given item. You are asked to decide whose price is closer to the real price.

Input

There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.

Each case contains three integers in one line: PPAPB (0 <= PAPB <= P <= 100, PA != PB), indicating the real price, the price A guesses and the price B guesses.

Output

For each case, output "A" or "B" according to whose price is closer to the real price.

Sample Input

3
10 8 7
20 20 19
100 9 50

Sample Output

A
A
B

题意:求两个价格哪个与实际价格更接近。

其实,题目有点纰漏,只说pa!=pb,但差值还是可能相等,不过测试样例里没有。


代码:

#include<iostream>
#include <cmath>
using namespace std;
int main()
{
	int t,p1,p2,p;
    cin>>t;
    while(t--)
    {
    	cin>>p>>p1>>p2;
    	if(abs(p-p1)<abs(p-p2))cout<<"A\n";
    	else cout<<"B\n";
    }
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值