Description
In the television program "Shopping Street" of CCTV-2, two people, A and B are guessing price of a given item. You are asked to decide whose price is closer to the real price.
Input
There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.
Each case contains three integers in one line: P, PA, PB (0 <= PA, PB <= P <= 100, PA != PB), indicating the real price, the price A guesses and the price B guesses.
Output
For each case, output "A" or "B" according to whose price is closer to the real price.
Sample Input
3 10 8 7 20 20 19 100 9 50
Sample Output
AAB
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
int pd (int pa,int a,int b)
{
int ca = fabs(pa - a);
int cb = fabs(pa - b);
if (ca > cb)
return 0;
else
return 1;
}
int main()
{
int N;
scanf ("%d",&N);
while (N--)
{
int pa,a,b;
scanf ("%d%d%d",&pa,&a,&b);
int tf = pd (pa,a,b);
if (tf)
puts ("A");
else
puts ("B");
}
return 0;
}