Doing Homework again 贪心

Doing Homework again

Time Limit: 1000MS Memory limit: 65536K

题目描述

 Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

输入

 The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

输出

 For each test case, you should output the smallest total reduced score, one line per test case.

示例输入

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

示例输出

0
3
5

提示

 

今天做贪心模块惊现好题。

这个题就是有个先SCF一样的人,本来平时分还不够还想尽量少减点。

于是有这么一样的任务,就是有n作业需要完成,每个作业用一天,每个作业的期限和不完成扣得分就是输入的。

然后求最少减分。

其贪心是这个样子的,先按分数排序,然后着重完成分数高的,如果天数不过,就放弃前面的天,分数低的。

其实现就是先排序,然后把最后一天标记,认为已用,然后按排序遍历,如果遇到时间冲突,就往前找天,如果有空余就使用。这样,实现贪心。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct m
{
    int day,sco,ok;
} a[100000];
int day[1000000];

int cmp (const void *a,const void *b)
{
    struct m *ta = (struct m *)a;
    struct m *tb = (struct m *)b;

    return tb->sco - ta->sco;
}

int main()
{
    int N;
    int n,m,i,k;

    while (~scanf ("%d",&N))
    {
        while (N--)
        {
            memset (a,0,sizeof (a));
            memset (day,0,sizeof (day));
            int ans = 0;
            scanf ("%d",&n);
            int md = 0;
            for (i = 0; i < n; i++)
            {
                scanf ("%d",&a[i].day);
                if (a[i].day > md)
                    md = a[i].day;
            }
            for (i = 0; i < n; i++)
            {
                scanf ("%d",&a[i].sco);
                ans += a[i].sco;
            }

            qsort (a,n,sizeof(a[0]),cmp);

            for(i = 0; i < n; i++)
            {
                if (day[a[i].day]== 0)
                {
                    day[a[i].day] = 1;
                    ans -= a[i].sco;
                }
                else
                {
                    for (k = a[i].day - 1; k > 0; k--)
                    {
                        if (day[k] == 0)
                        {
                            day[k] = 1;
                            ans -= a[i].sco;
                            break;
                        }
                    }
                }
            }
            printf ("%d\n",ans);
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值