Doing Homework again——贪心

问题:

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题意:

给你完成作业的最后期限,和不能按时完成作业要扣的分数,问怎样安排时间才能使扣得分降到最低。

思路:

因为要求扣分最少,所以我们可以先把扣分较多的科目安排好在那一天完成,为了给其他科目留出时间,可以把完成时间安排在距最后期限最近的未被安排的那一天里。

代码:

#define N 1111
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,t,book[N];

struct node
{
    int a,b;//a是最后期限,b是扣分
} k[N];

double cmp(node x,node y)
{
    return x.b>y.b;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        memset(book,0,sizeof(book));
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%d",&k[i].a);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&k[i].b);
            sum+=k[i].b;    //假设所有科目都没完成的总扣分
        }
        sort(k,k+n,cmp);    
        for(int i=0; i<n; i++)//按扣分由多到少以次遍历
        {
            int d=k[i].a;
            while(d)//期限之内,寻找合适的完成时间
            {
                if(!book[d])   //可以安排在这一天(未被安排过的)
                {
                    book[d]=1; //安排上
                    sum-=k[i].b;  //扣分减少 
                    break;
                }
                d--;  
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值