九度OJ-1012:畅通工程(用并查集求连通分量数)

  本题可抽象为求无向图的连通分量数。

  求无向图连通分量数可使用并查集来实现。

  算法:初始化孤点,通过输入边不断并集。然后遍历求出集合数(==-1),即为连通分量数。

debug记录:

  ①编写unionSet函数:

void unionSet(int x,int y){
	int xroot=findRoot(x),yroot=findRoot(y);
	if (xroot!=yroot)//if x and y are from different set 
	elem[xroot]=yroot; //merge xset into yset 
}
必须要判断if (xroot!=yroot)才能进行并集,否则会出现elem[root]=root的坑爹情况(如果root为根的话,elem[root]应该要=-1)。

题目描述:

    某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

输入:

    测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
    注意:两个城市之间可以有多条道路相通,也就是说
    3 3
    1 2
    1 2
    2 1
    这种输入也是合法的
    当N为0时,输入结束,该用例不被处理。

输出:

    对每个测试用例,在1行里输出最少还需要建设的道路数目。

样例输入:
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
样例输出:
1
0
2
998
来源:
2005年浙江大学计算机及软件工程研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7736-1-1.html
#include <iostream> 
#define MAXSIZE 1000
using namespace std;
struct UFS{//UnionFindSet 从0开始 
	int elem[MAXSIZE];
	int size;
	void initiate(int size){
		this->size=size;
		for (int i=0;i<size;i++)
			elem[i]=-1;
	}
	int findRoot(int x){
		if (elem[x]==-1) 
			return x;
		else 
			return findRoot(elem[x]);
	}
	void unionSet(int x,int y){
		int xroot=findRoot(x),yroot=findRoot(y);
		if (xroot!=yroot)//if x and y are from different set 
			elem[xroot]=yroot; //merge xset into yset 
	}
};

int main(){
	int n,m;
	int a,b;
	int component;
	UFS ufs;
	while (cin>>n>>m,n){//n vexes,m edges
		//initiate
		ufs.initiate(n);
		component=0;
		//union
		for (int i=0;i<m;i++){
			cin>>a>>b;
			ufs.unionSet(a-1,b-1);
		}
		//count roots
		for (int i=0;i<n;i++){
			if (ufs.elem[i]==-1)
				component++;	
		}
		//output
		cout<<component-1<<endl;
	}
	return true;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值