HDU 4715 Difference Between Primes

Problem Description
All you know Goldbach conjecture.That is to say, Every even integer greater than 2 can be expressed as the sum of two primes. Today, skywind present a new conjecture: every even integer can be expressed as the difference of two primes. To validate this conjecture, you are asked to write a program.
 

Input
The first line of input is a number nidentified the count of test cases(n<10^5). There is a even number xat the next nlines. The absolute value of xis not greater than 10^6.
 

Output
For each number xtested, outputstwo primes aand bat one line separatedwith one space where a-b=x. If more than one group can meet it, output the minimum group. If no primes can satisfy it, output 'FAIL'.
 

Sample Input
  
  
3 6 10 20
 

Sample Output
  
  
11 5 13 3 23 3

模拟就能做,先保存后查询。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
map<int,int>a;

bool isprime(int num)
{
    if (num == 2 || num == 3)
    {
        return true;
    }
    if (num % 6 != 1 && num % 6 != 5)
    {
        return false;
    }
    for (int i = 5; i*i <= num; i += 6)
    {
        if (num % i == 0 || num % (i+2) == 0)
        {
            return false;
        }
    }
    return true;
}
int main()
{
    for(int i=2; i<=3110011; i++)
    {
        if(isprime(i))
            a[i]++;
    }
    int t,x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&x);
        map<int,int>::iterator ai;
        int flag=0;
        if(x>0)
        {

            for(ai=a.begin(); ai!=a.end(); ai++)
            {

                if(isprime(ai->first+x))
                {
                    printf("%d %d\n",ai->first+x,ai->first);
                    flag=1;
                    break;

                }
            }
            if(!flag)
            {
                printf("FAIL\n");
            }
        }
        else
        {

            for(ai=a.begin(); ai!=a.end(); ai++)
            {

                if(isprime(ai->first-x))
                {
                    printf("%d %d\n",ai->first,ai->first-x);
                    flag=1;
                    break;

                }
            }
            if(!flag)
            {
                printf("FAIL\n");
            }
        }

    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值