Goldbach

题目描述

The Goldbach’s Conjecture is stated like the following:
Every even number greater than 4 can be written as the sum of two odd prime numbers.
Your task is now to verify Goldbach\'s Conjecture for all even numbers less than a million.

输入

The input contains multiple test cases. Each test case consisted of an even integer n with 6 < n < 1000000. Input will be terminated by 0.

输出

For every test case, print one line of the form “n = a + b”, a < b, without quotes. Where a and b are odd prime numbers. If there is more than one pair of odd primes, you are to print the pair a, b with the maximized difference b - a. If there are no such pair, print a line saying “Goldbach\'s conjecture is wrong.”.

示例输入

8
20
0

示例输出

8 = 3 + 5
20 = 3 + 17

提示

#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

int a[1000000];
int check[1000000];
int main()
{
    int i, j, n, tot=0, x;
    memset(check,0,sizeof(check));
    for(i=2;i<=1000000;i++)
    {
        if(!check[i])
            a[tot++]=i;
        for(j=0;j<tot;j++)
        {
            if(i*a[j]>=1000000)
                break;
            check[i*a[j]]=1;
            if(i%a[j]==0)
                break;
        }
    }
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        x=0;
        for(i=2;i<n;i++)
        {
            if(check[i]==0&&check[n-i]==0)
            {
                printf("%d = %d + %d\n",n,i,n-i);
                x=1;
                break;
            }
        }
        if(x==0)
            printf("Goldbach's conjecture is wrong.\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值