POJ 1328 Radar Installation(贪心)

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

这道题就是一道贪心题,思路并不难,但是悲催的是WA了5次,居然是因为如果不符合条件时输出-1时直接输出了-1,前面没带Case。。。。sad。。。害得我把点的排序按点排了一次,又按区间左端点排了一次。。不过事后发现这两种排序都可以。。
本题贪心思路是把点转化为在x轴坐标上的区间(即能保证覆盖该小岛的雷达所有可能位置的集合),然后按点的顺序排也行,按左端点排也行。然后最左边的依次向右遍历,如果下一个区间的最左端在上一个雷达的右端,显然需要放一个新雷达;如果在左端的话,则需要判断最右端了,如果最右端也在上个雷达左端的话,那么这个雷达显然不能覆盖当前这个小岛,需要把雷达位置调整为当前区间的最右端,这样既能覆盖之前的也能覆盖现在的;如果最右端在上个雷达右端,则无需调整也无需放置新雷达。
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct node
{
    double zuo, you;
} fei[2100], t;
int cmp(node a, node b)
{
    return a.zuo < b.zuo;
}
int x[2100],y[2100];
int main()
{
    int i, j, n, d, num, flag, s=0;
    double z, p;
    while(scanf("%d%d",&n,&d)!=EOF)
    {
        if(n==0&&d==0) break;
        s++;
        flag=0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            if(y[i]>d)
                flag=1;
        }
        if(flag)
            printf("Case %d: -1\n",s);
        else
        {
            for(i=0; i<n; i++)
            {
                z=sqrt(d*d*1.0-y[i]*y[i]*1.0);
                fei[i].zuo=(double)x[i]-z;
                fei[i].you=(double)x[i]+z;
            }
            sort(fei,fei+n,cmp);
            num=0;
            p=-100000000;
            for(i=0; i<n; i++)
            {
                if(fei[i].zuo>p)
                {
                    num++;
                    p=fei[i].you;
                }
                else if(fei[i].you<p)
                {
                    p=fei[i].you;
                }
            }
            printf("Case %d: %d\n",s,num);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值