UVAOJ 465 ——Overflow 模拟(坑题)

15 篇文章 0 订阅

 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big


做大数做的我还以为这是个大数呢,用double就能过。。。



#include <stdio.h>
#include <string.h>
#include <limits.h>
#include <stdlib.h>

const int inf = INT_MAX;
int main()
{
    double a,b;
    char s1[1010],s2[10],s3[1010];
    while(~scanf("%s%s%s",s1,s2,s3))
    {
        printf("%s %c %s\n",s1,s2[0],s3);
        a = atof(s1);
        b = atof(s3);
        if(s2[0] == '+')
        {
            if(a > inf)
                printf("first number too big\n");
            if(b > inf)
                printf("second number too big\n");
            if(a + b > inf)
                printf("result too big\n");
        }
        if(s2[0] == '*')
        {
            if(a > inf)
                printf("first number too big\n");
            if(b > inf)
                printf("second number too big\n");
            if(a * b > inf)
                printf("result too big\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值