POJ 3041 Asteroids 最小点覆盖==最大二分匹配

Asteroids
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 16213
Accepted: 8821

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source


题意:在一个N*N的矩阵中 有K个障碍物,你有一个武器 每次使用 可以清除某行 或 某列 的障碍物,但是这种武器非常昂贵,所以你要尽可能少的使用;输出 最少使用多少次武器 可以清除所有的障碍物;


最小点覆盖==最大二分匹配


16MS     AC

#include <stdio.h>
#include <string.h>

bool mp[510][510];
int flag[10010];
bool vis[510];

bool dfs(int u,int n)
{
    for(int i = 1;i <= n;i++)
    {
        if(mp[u][i] && !vis[i])
        {
            vis[i] = true;
            if(!flag[i] || dfs(flag[i],n))
            {
                flag[i] = u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int n,m,x,y,cnt = 0;
    scanf("%d%d",&n,&m);
    memset(mp,false,sizeof(mp));
    memset(flag,0,sizeof(flag));
    for(int i = 0;i < m;i++)
    {
        scanf("%d%d",&x,&y);
        mp[x][y] = true;
    }
    for(int i = 1;i <= n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(dfs(i,n))
            cnt++;
    }
    printf("%d\n",cnt);
    return 0;
}

0MS     AC


#include <stdio.h>
#include <string.h>

bool vis[510];
struct node
{
    int v;
    int next;
}ls[10010];
int head[510];
int flag[10010];
int num = 0;

void creat(int x,int y)
{
    ls[num].v = y;
    ls[num].next = head[x];
    head[x] = num++;
}

bool dfs(int u,int n)
{
    for(int i = head[u];~i;i = ls[i].next)
    {
        int v = ls[i].v;
        if(!vis[v])
        {
            vis[v] = true;
            if(!flag[v] || dfs(flag[v],n))
            {
                flag[v] = u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int n,m,x,y,cnt = 0;
    memset(head,-1,sizeof(head));
    memset(flag,0,sizeof(flag));
    scanf("%d%d",&n,&m);
    for(int i = 0;i < m;i++)
    {
        scanf("%d%d",&x,&y);
        creat(x,y);
    }
    for(int i = 1;i <= n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(dfs(i,n))
            cnt++;
    }
    printf("%d\n",cnt);
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值