POJ 3041 Asteroids 二分匹配 最小点覆盖

原题: http://poj.org/problem?id=3041

题目:

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17751 Accepted: 9645
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
    Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.
    Sample Input

3 4
1 1
1 3
2 2
3 2
Sample Output

2
Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

思路:

有点像大鸟那个题,每一枪可以打死一整排或者一整列的鸟,如何开最小次数枪打完所有鸟。

一般情况下我们建图都是建的邻接矩阵,每个点代表该横纵坐标下的点的鸟的个数。
那样我们是以坐标数据为边,以鸟为点。
如果我们以鸟为边,以边为点,只需要让每条边至少有一个点被标记(该行或者该列打了一枪)就可以了。
这就是二分匹配的最小点覆盖。

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<vector>
using namespace std;
#define N 505
int n,m;
vector<int>v[N];
bool flag[N];
int ans[N];

bool dfs(int x)
{
    int len=v[x].size();
    for(int i=0; i<len; i++)
    {
        int ed=v[x][i];
        if(flag[ed]==0)
        {
            flag[ed]=1;
            if(ans[ed]==-1||dfs(ans[ed]))
            {
                ans[ed]=x;
                return 1;
            }
        }
    }
    return 0;
}
int maxmatch()
{
    int num=0;
    memset(ans,-1,sizeof(ans));
    for(int i=1; i<=n; i++)
    {
        memset(flag,0,sizeof(flag));
        if(dfs(i))
            num++;
    }
    return num;
}
int main()
{
    int x,y;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<N; i++)  v[i].clear();
        while(m--)
        {
            scanf("%d%d",&x,&y);
            v[x].push_back(y);
        }
        printf("%d\n",maxmatch());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值