poj-3041 Asteroids(最小点覆盖)

题意描述:
给出小行星的坐标,让你求出用最少的次数来消灭小行星,一次可以消灭一横排,或者一竖排的小行星;
实际上这个题目和我以前遇到的消除矩阵中的一是一样的题,那一次是直接给出矩阵,这次只是换成了坐标而已有兴趣的话可以去看看题目链接https://vjudge.net/problem/22270/origin
都属于二分匹配最小点覆盖问题
原文题目
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
Line 1: Two integers N and K, separated by a single space.
Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
AC代码:

#include<stdio.h>
#include<string.h>
int e[1010][1010];
int book[1010],match[1010];
int n,m,k;
int dfs(int u)
{
	for(int i=1; i<=n; i++)
	{
		if(book[i]==0&&e[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int sum,t1,t2;
	while(scanf("%d %d", &n,&m)!=EOF)
	{
		memset(match,0,sizeof(match));
		memset(e,0,sizeof(e));
		sum=0;
	for(int i=1; i<=m; i++)
	{
		scanf("%d %d", &t1,&t2);
		e[t1][t2]=1;
	}
	for(int i=1; i<=n; i++)
	{
		memset(book,0,sizeof(book));
		if(dfs(i))
		sum++;
	}
	printf("%d\n", sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值