Time Limit: 5000MS | Memory Limit: 131072K | |
Total Submissions: 59247 | Accepted: 18032 | |
Case Time Limit: 2000MS |
Description
You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4
Sample Output
4 55 9 15
Hint
Source
#include <cstdio>
#include <cstring>
#define LL long long int
LL a[100010] , b[100010] , c[100010] ;
int lowbit(int x)
{
return x & -x;
}
void add(LL *s,int i,int x,int n)
{
while( i <= n )
{
s[i] += x ;
i += lowbit(i) ;
}
}
LL get(LL *s,int i)
{
LL sum = 0;
while( i )
{
sum += s[i] ;
i -= lowbit(i) ;
}
return sum;
}
LL f(int i)
{
LL sum = a[i] ;
sum += ( (i+1)*get(b,i) - get(c,i) ) ;
return sum ;
}
int main()
{
int i , n , m , l , r ;
LL x , sum ;
char ch ;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
scanf("%d %d", &n, &m);
for(i = 1 ; i <= n ; i++)
{
scanf("%lld", &x);
a[i] += a[i-1] + x ;
}
while(m--)
{
getchar();
scanf("%c", &ch);
if(ch == 'Q')
{
scanf("%d %d", &l, &r);
sum = f(r) - f(l-1) ;
printf("%lld\n", sum) ;
}
else
{
scanf("%d %d %d", &l, &r, &x);
add(b,l,x,n) ;
add(b,r+1,-x,n);
add(c,l, x*l ,n);
add(c,r+1, -(x*(r+1)),n);
}
}
return 0;
}