poj2182--Lost Cows

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9116 Accepted: 5850

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

USACO 2003 U S Open Orange
题意:n头牛,每头牛有[1,n]的独立的编号,现在这些牛杂乱的站在一排,给出在第i头牛之前,并且比第i头牛编号小的个数,i属于2到n。求解现在的每头牛的编号
二分+树状数组
由后向前找,第i头牛的值k代表着,该牛是在还未出现的牛中的第k+1个。使用树状数组统计当前编号为j(j属于1到n)之前有多少还未出现的牛(统计结果包含j,),因为这样统计出来的未出现的数目是有小到大的,可以用二分,找出该牛应该的编号
注意,当一个编号已经用过了,就不能在使用了,避免的方法是,当编码对应的值相同时,尽量选择靠左的编码。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int c[8010] , a[8010] , b[8010];
int flag[8010] ;
int lowbit(int x)
{
    return x & -x ;
}
void add(int i,int n,int d)
{
    while(i <= n)
    {
        c[i] += d ;
        i += lowbit(i) ;
    }
}
int sum(int i)
{
    int k = 0 ;
    while(i)
    {
        k += c[i] ;
        i -= lowbit(i) ;
    }
    return k ;
}
int f(int x,int n)
{
    int low = 0 , high = n , mid , k ;
    while( low <= high )
    {
        mid = (low + high) / 2 ;
        k = sum(mid) ;
        if( k == x )
            {
                if(low == high)
                    break;
                else
                    high = mid ;
            }
        else if( k < x )
            low = mid + 1 ;
        else
            high = mid - 1 ;
    }
    add(mid,n,-1);
    flag[mid] = 1 ;
    return mid ;
}
int main()
{
    int i , n ;
    memset(c,0,sizeof(c));
    memset(flag,0,sizeof(flag));
    memset(b,-1,sizeof(b));
    scanf("%d", &n);
    for(i = 1 ; i < n ; i++)
        scanf("%d", &a[i]);
    a[0] = 0 ;
    for(i = 1 ; i <= n ; i++)
    {
        add(i,n,1);
    }
    for( i = n-1 ; i >= 0 ; i--)
    {
        b[i] = f(a[i]+1,n);
    }
    for(i = 0 ; i < n ; i++)
    {
            printf("%d\n", b[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值