poj1159--Palindrome(dp:最长公共子序列变形 + 滚动数组)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 53414 Accepted: 18449

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.  

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.  

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

IOI 2000
题目大意:添加最少的字符,使得字符串变为回文串
如果一个字符串是回文串,那么它与它的逆序数组的最长公共子序列为自身的长度,所以求出最长公共子序列的长度后,用总的长度减去它,得到的就是要修改的长度。

使用short的5000*5000的数组

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
short dp[5100][5100] ;
char str1[5100] , str2[5100] ;
int main()
{
    int i , j , n ;
    while(scanf("%d", &n) !=EOF)
    {
        scanf("%s", str1);
        for(i = 0 ; i < n ; i++)
            str2[n-1-i] = str1[i] ;
        str2[i] = '\0' ;
        for(i = 1 ; i <= n ; i++)
            for(j = 1 ; j <= n ; j++)
            {
                if( str1[i-1] == str2[j-1] )
                    dp[i][j] = dp[i-1][j-1]+1 ;
                else
                    dp[i][j] = max( dp[i-1][j],dp[i][j-1] );
            }
        printf("%d\n", n-dp[n][n]);
    }
    return 0;
}


使用滚动数组

滚动数组:使用两行数组,模拟大的二维数组

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[2][5100] ;
char str1[5100] , str2[5100] ;
int main()
{
    int i , j , n , k ;
    while(scanf("%d", &n) !=EOF)
    {
        scanf("%s", str1);
        for(i = 0 ; i < n ; i++)
            str2[n-1-i] = str1[i] ;
        str2[i] = '\0' ;
        k = 0 ;
        for(i = 1 ; i <= n ; i++)
        {
            k = 1 - k ;
            for(j = 1 ; j <= n ; j++)
            {
                if( str1[i-1] == str2[j-1] )
                    dp[k][j] = dp[1-k][j-1]+1 ;
                else
                    dp[k][j] = max( dp[1-k][j],dp[k][j-1] );
            }
        }
        printf("%d\n", n-dp[k][n]);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值