POJ1159 Palindrome (动态规划)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 61980 Accepted: 21598

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意:给一个字符串,问最少加几个字符使得他成为回文串。

题目分析:将这个字符串倒过来与原字符串求最长公共子序列,用总长度减去求得的子序列长度就是。(至于为什么这样可以,仔细想一想就明白了)

然而这个题目用一般的求法会爆内存,此时需要用到滚动数组。因为在每一个动规方程中,使用到的数组只有两层(详见背包九讲),故可以节省大量空间。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
int dp[2][5000+10];
int n;char c[5000+10],s[5000+10];
int main(){
while(scanf("%d",&n)==1)
{
    scanf("%s",c);
    int len=strlen(c);
    for(int i=len-1,j=1;i>=0;i--)s[j++]=c[i];
    memset(dp,0,sizeof(dp));
    int e=0;
    for(int i=0;i<len;i++)
    {
        e=1-e;
        for(int j=1;j<=len;j++)
        {
         if(c[i]==s[j])dp[e][j]=dp[1-e][j-1]+1;
            else{
             dp[e][j]=max(dp[1-e][j],dp[e][j-1]);
            }
        }
    }
printf("%d\n",n-dp[e][len]);
}

return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值