poj3267--The Cow Lexicon(dp:字符串组合)

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8211 Accepted: 3864

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:   W  and   L  
Line 2:   L  characters (followed by a newline, of course): the received message  
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

USACO 2007 February Silver
给出一个字符串,问最少去掉几个字符得到的序列是完全由给出的字典组成,字典在下面给出
根据问题,可以想到最后得到的字符串是字典组成的,那么组成这个字符串的单词在一开始就分散在给出的串中,我们要找的就是判断单词在字符串的位置。
dp[i]表示从头开始到第i个字符最少要消除多少个字符,
首先dp[0] = 1 ;
dp[i] = dp[i-1] , 匹配不到
dp[i] = dp[j] + k 出现字符串可以匹配到从j+1到i的字符串中,k = 从j+1到i完成匹配需要消除的字符。
一开始用最长公共子序列写,后来发现,在对dp[i]寻找从0到i有没有单词可以匹配的时候,要求,单词的最后一个单词一定和s[i]相同,不然那个单词在之前就已经匹配过了。
所以只要用普通的遍历就可以了。
PS:对于不知道开始或结束的位置的字符串判字串,用最长公共子序列,如果知道一个确定的位置,直接匹配。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
    int l ;
    char s[30] ;
} p[700];
int dp[400];
char s[400] ;
int cmp(node a,node b)
{
    return a.l < b.l ;
}
int main()
{
    int i , j , n , l ;
    while( scanf("%d %d", &n, &l)!=EOF)
    {
        scanf("%s", s);
        for(i = 0 ; i < n ; i++)
        {
            scanf("%s", p[i].s);
            p[i].l = strlen(p[i].s);
        }
        sort(p,p+n,cmp);
        memset(dp,0,sizeof(dp));
        dp[0] = 1 ;
        for(i = 0 ; i < l ; i++)
        {
            if(i)
                dp[i] = dp[i-1]+1 ;
            for( j = 0 ; p[j].l <= i+1 ; j++)
            {
                int k1 = i , k2 = p[j].l-1 ;
                if( s[k1] != p[j].s[k2] ) continue ;
                while( k1 >= 0 && k2 >= 0 )
                {
                    if( s[k1] == p[j].s[k2] )
                    {
                        k1-- ;
                        k2-- ;
                    }
                    else
                        k1-- ;
                }
                if( k2 == -1 )
                {
                    dp[i] = min( dp[i],dp[k1]+i-k1-p[j].l );
                }
            }
        }
        printf("%d\n", dp[l-1]);
    }
    return 0;
}

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值