poj3070--Fibonacci(矩阵的快速幂)

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9650 Accepted: 6856

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

和普通的快速幂的写法相同,不同的是需要计算矩阵相乘,只要写对矩阵的乘法,就没难度了
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define LL long long
struct node{
    LL s11 , s12 , s21 , s22 ;
};
node f(node a,node b)
{
    node p ;
    p.s11 = (a.s11*b.s11 + a.s12*b.s21)%10000 ;
    p.s12 = (a.s11*b.s12 + a.s12*b.s22)%10000 ;
    p.s21 = (a.s21*b.s11 + a.s22*b.s21)%10000 ;
    p.s22 = (a.s21*b.s12 + a.s22*b.s22)%10000 ;
    return p ;
}
node pow(node p,int n)
{
    node q ;
    q.s11 = q.s22 = 1 ;
    q.s12 = q.s21 = 0 ;
    if(n == 0)
        return q ;
    q = pow(p,n/2);
    q = f(q,q);
    if( n%2 )
        q = f(q,p);
    return q ;
}
int main()
{
    int n ;
    node p ;
    while(scanf("%d", &n) && n != -1)
    {
        p.s11 = p.s12 = p.s21 = 1 ;
        p.s22 = 0 ;
        p = pow(p,n);
        printf("%d\n", p.s12);
    }
    return 0;
}

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值