Poj 3070 矩阵快速幂(找规律法)

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

这道题的意思就是让你输出第N个斐波那契数列的后四位是什么,不用保留前导零。这题的数据非常之大。就算O(n)的算法也会超时,当然这个题正确的解法是矩阵快速幂,不过这个题目比较特殊,通过时建坤大佬得知,结果是会循环然后通过测试得知结果是会循环的。
我们开一个非常大的数组,只保留后四位,即对1e4进行取余,这样并不会影响结果,按照加法的算法,低位次会对高位次产生影响,但高位次不会对低位次产生影响。当我们发现后面的数中如果又出现了这一位是1,前一位是0,即发生了循环。我得到他的循环长度。然后对循环长度取余数再从数组中输出就行了,完整代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>

using namespace std;

const int MAX = 1e6+10;
const int mod = 1e4;
int f[MAX];

int Getans(){
    f[0] = 0;f[1] = 1;
    for(int i=2;i<=MAX-10;++i){
        f[i] = (f[i-1] + f[i-2]) % mod;//在数组中只保留后四位。
        if(f[i] == 1 && f[i-1] == 0){//又一次到达最开始的数,因此会循环
            return (i-1);//从第i-1个开始循环,循环最后一个数是i-2,因为从0开始所以其循环长度是i-1,因此我们对i-1取余数。
        }
    }
    return false;
}
int main(void){
    int Len = Getans();
    int n;
    while(cin >> n && n!= -1){
        cout << f[n%Len] << endl;
    }
    return 0;
}

矩阵快速幂的做法如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<iostream>
#include<algorithm>
#include<set>

using namespace std;
const int mod = 10000;
typedef vector<int> vec;
typedef vector<vec> mat;
typedef long long ll;
mat mul(mat &A,mat &B){
    mat C(A.size(),vec(B[0].size()));
    for(int i=0;i<A.size();i++){
        for(int j=0;j<B[0].size();j++){
            for(int k = 0;k<B.size();k++){
                C[i][j] = (C[i][j] + A[i][k]*B[k][j]) %mod;
            }
        }
    }
    return C;
}

mat pow(mat A,ll n){
    mat B(A.size(),vec(A.size()));
    for(int i=0;i<A.size();i++) B[i][i] = 1;
    while(n){
        if(n&1) B = mul(B,A);
        A = mul(A,A);
        n >>= 1;
    }
    return B;
}
int main(void){
    mat A(2,vec(2));//申请2个存放vec类型的mat,而且vec里面只有2个元素
    ll n;
    while(scanf("%lld",&n) && n!=-1){
        A[0][0] = A[0][1] = A[1][0] = 1;
        A[1][1] = 0;

        A = pow(A,n);
        printf("%d\n",A[1][0]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值