Kindergarten Counting Game

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9
#include <stdio.h>
#include <string.h>

int main()
{
   char st[10000] = {'\0'};
   char *p = st;
   int i = 0,l,j,bo = 0,sum = 0;

   while(gets(st)!=NULL)
   {
       sum = 0;bo = 0;i = 0;
   l = strlen(st);
    if((st[0]>='A' && st[0]<='Z')||(st[0]>='a' && st[0]<='z'))
        bo = 1;
    else
        bo = 0;
   for(j = 1;j<l;j++)
   {
       if((st[j]>='A' && st[j]<='Z')||(st[j]>='a' && st[j]<='z'))
        bo = 1;
        else
        {
            if(bo == 1)
                {
                sum++;
                bo = 0;
                }
        }
    }
   printf("%d\n",sum);
   }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值