Everybody sit down in a circle. Ok. Listen to me carefully.
``Woooooo, you scwewy wabbit!''
Now, could someone tell me how many words I just said?
Input and Output
Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).
Your program should output a word count for each line of input. Each word count should be printed on a separate line.
Sample Input
Meep Meep! I tot I taw a putty tat. I did! I did! I did taw a putty tat. Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...
Sample Output
2 7 10 9
/*
很水的一道题,没什么可说的
*/
#include <stdio.h>
#include <string.h>
#include <ctype.h>
int main()
{
freopen("c:\\in.txt","r",stdin);
char str[2000];
int countn, size;
int i;
while (fgets(str,2000,stdin)!=NULL)
{
size = strlen(str);
i = 0;
countn = 0;
while (i<size)
{
if ((isalpha(str[i]) && !isalpha(str[i-1]))
|| (isalpha(str[i]) && i==0))
{
countn++;
i+= 2;
}
else ++i;
}
printf("%d\n",countn);
}
return 0;
}