Power Strings

Power Strings

Time Limit: 1000MS Memory limit: 65536K

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

输入

  Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

  For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.

示例输出

1
4
3

提示

  This problem has huge input, use scanf instead of cin to avoid time limit exceed.

计算一个字符串是由一个字串复制多少次组成,同样是KMP的灵活运用。关键是KMP中字符串next值的计算过程以及每个值的意义。
如果一个字符串重复的出现,则next值在第二个循环节开始即从1开始不断的增长,其实是公差为1的等差数列。在next值计算完成后从后往前便利,遇到的第一个为0的元素即使最小字符串的最后一个元素,为了防止出现abcabcab(其next值为:-1,0,0,1,2,3,4,5),当找到第一个0对应的元素“c”时,即便条件成立,但前面的“abc”却不是最小子串,因为最后面的字符是“ab”而不是“abc”,所以一个最小循环串的长度一定要可以被整条串的长度整除才行。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

char st[1000009];
int next[1000009];
int main()
{
    int i,j,l;
    while(~scanf("%s",st))
    {
        if(st[0] == '.' && st[1] == '\0')
            break;
        l = strlen(st);
        i = 0;j = -1;next[0] = -1;
        while(i<l)
        {
            if(j == -1 || st[i] == st[j])
            {
                i++;
                j++;
                next[i] = j;
            }
            else
                j = next[j];
        }
        i = i - j;
        if(l % i == 0)
            i = l / i;
        printf("%d\n",i);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值