问题 D: 4.5.17 Power Strings[kmp][最大连续子串]

11 篇文章 0 订阅

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

 

输入

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

 

输出

For each s you should print the largest n such that s = a^n for some string a.

 

样例输入

abcd
aaaa
ababab
.

样例输出

1
4
3

提示

#include<cstdio>
#include<string.h>
#define max 2000002
using namespace std;
long long ne[max];
char s[max];
void kmp()
{
    ne[0]=-1;
    long long i=0,j=-1;
    long long L=strlen(s);
    while(i<L)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            ne[i]=j;
        }
        else
        j=ne[j];
    }
}
int main()
{
    while(scanf("%s",s)&&s[0]!='.')
    {
        kmp();
        long long L=strlen(s);
        if(L%(L-ne[L])==0)
        {
            printf("%d\n",L/(L-ne[L]));
        }
        else
        printf("1\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值