【九度】题目1461:Tempter of the bone

108 篇文章 0 订阅
102 篇文章 5 订阅
题目地址:http://ac.jobdu.com/problem.php?pid=1461
题目描述:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入:

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed. 

输出:

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

样例输入:
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
样例输出:
NO
YES

题目大意:
 一只小狗在迷宫中发现一根骨头,但是当他捡起骨头的是,地面就开始晃动。现在他要逃出迷宫。每次他可以向左右上下四个方向移动。在第T秒,迷宫出口的门打开。问他能否逃出迷宫。
题目分析:
 解决迷宫类似问题,如果是能不能到达,一般选用的是dfs,如果是求最短步数,一般选用的是bfs。
基本思路:
 本题要求的是yes或者是no,所以可以选用dfs。
 1、输入数据存储至结构体;
 2、从开始节点开始依次访问,发现到出口了,并且时间恰好等于T就成功了,否则继续,直到循环结束。
 3、比较打印结果。
C++ AC代码

#include <stdio.h>
#include <stdlib.h>
#include<queue>
using namespace std;
const int maxn = 8;
int visit[maxn][maxn];
char mazeArr[maxn][maxn];
int step[4][2] = {{-1,0},{1,0},{0,-1},{0,1}};
int n , m ,t;
bool success;
int i,j;
    
void dfs(int x, int y ,int time) {
    for (int i = 0; i < 4; i++) {
        int sx = x + step[i][0];
        int sy = y + step[i][1];
        if (sx < 0 || sy < 0 || sx > n-1 || sy > m-1){
            continue;
        }
        if (mazeArr[sx][sy] == 'X') {
            continue;
        }
        if (visit[sx][sy] == 1) {
            continue;
        }
              
        if (mazeArr[sx][sy] == 'D') {
            if (time + 1 == t) {
                success = true;
                return;
            }else {
                continue;
            }
        }
        visit[sx][sy] = 1;
        dfs(sx, sy, time+1);
        visit[sx][sy] = 0;
        if (success) {
            return;
        }
    }
}
  
int main(){ 
  
    while(scanf("%d%d%d",&n,&m,&t) != EOF ){
        if(n == 0 && m ==0 && t == 0){
            break;
        }
  
        for(i = 0; i < n ; i++){
            scanf("%s",mazeArr[i]);
                  
        }
        int startx;
        int starty;
        for( i = 0; i < n ; i++){
            for(j = 0; j < m ; j++){
                if(mazeArr[i][j] == 'S'){
                    startx = i;
                    starty = j;
                }
                visit[i][j] = 0;
            }
        }
        success = false;
        dfs(startx , starty, 0);
        printf("%s\n", success == true ? "YES":"NO");
    }
     
    return 0;
}
/**************************************************************
    Problem: 1461
    User: wangzhenqing
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1020 kb
****************************************************************/

Java AC代码

import java.util.Scanner;
  
public class Main {
    /*
     * 1461
     */
    private static char mazeArr[][];
    private static int visit[][];
    private static int step[][] = {{-1,0},{1,0},{0,-1},{0,1}};
    private static int n ,m ,t;
    private static boolean success;
    public static void main(String[] args){
        Scanner scanner = new Scanner(System.in);
        while (scanner.hasNext()) {
            n = scanner.nextInt();
            m = scanner.nextInt();
            t = scanner.nextInt();
            if (n == 0 && m == 0 && t == 0) {
                break;
            }
            mazeArr = new char[n][m];
            visit = new int[n][m];
            for (int i = 0; i < n; i++) {
                String tempStr = scanner.next();
                mazeArr[i] = tempStr.toCharArray();
            }
            int startx = 0;
            int starty = 0;
            for (int i = 0; i < n; i++) {
                for (int j = 0; j < m; j++) {
                    if (mazeArr[i][j] == 'S') {
                        startx = i;
                        starty = j;
                    }
                }
            }
             
            success = false;
            dfs(startx, starty, 0);
            if (success) {
                System.out.println("YES");
            }else {
                System.out.println("NO");
            }
        }
    }
 
    private static void dfs(int x, int y, int time) {
        for (int i = 0; i < 4; i++) {
            int sx = x + step[i][0];
            int sy = y + step[i][1];
            if (sx < 0 || sy < 0 || sx > n-1 || sy > m-1){
                continue;
            }
            if (mazeArr[sx][sy] == 'X') {
                continue;
            }
            if (visit[sx][sy] == 1) {
                continue;
            }
             
            if (mazeArr[sx][sy] == 'D') {
                if (time + 1 == t) {
                    success = true;
                    return;
                }else {
                    continue;
                }
            }
            visit[sx][sy] = 1;
            dfs(sx, sy, time+1);
            visit[sx][sy] = 0;
            if (success) {
                return;
            }
        }
    }
}
 
/**************************************************************
    Problem: 1461
    User: wzqwsrf
    Language: Java
    Result: Accepted
    Time:170 ms
    Memory:19760 kb
****************************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值