HDU 1789 Doing Homework again

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1789

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5

题目大意:第一行输入表示T个测试例子,接下来的每个例子包括n个作业,每个作业有最后提交的期限(剩下多少天)和若未完成相应扣的分数(第二行)。贪心法,为了最小化扣的分数,对分数从大到小排序,优先完成分值大的作业。标记一下完成的作业,最后即可算出扣的分数。

代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
#define N 1001
typedef struct{
	int deadline;
	int reduced;
	int status;
}homework;
homework score[N];
bool cmp(homework a,homework b){
	if(a.reduced==b.reduced)
		return a.deadline<b.deadline;
	return a.reduced>b.reduced;
}
int main()
{
//	freopen("E:\\in.txt","r",stdin);
	int T;
	cin>>T;
	while(T--){
		int done[N];
		memset(done,0,sizeof(done));
		int n,i,j,res=0;
		cin>>n;
		for(i=0;i<n;i++)
			cin>>score[i].deadline;
		for(i=0;i<n;i++)
			cin>>score[i].reduced;
		for(i=0;i<n;i++)
			score[i].status=0;
		sort(score,score+n,cmp);
//		for(i=0;i<n;i++)		//查看排序后的结果
//			cout<<score[i].deadline<<" "<<score[i].reduced<<endl;
//		cout<<endl;
		for(i=0;i<n;i++){
			for(j=score[i].deadline-1;j>=0;j--){
				if(done[j]==0){
					done[j]=1;
					score[i].status=1;//标记该项已完成
//					cout<<score[i].deadline<<" "<<score[i].reduced<<endl;
					break;
				}
			}
			if(score[i].status==0){
				res+=score[i].reduced;
//				cout<<score[i].deadline<<" "<<score[i].reduced<<endl;
			}
		}
		cout<<res<<endl;	
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值