HDU 1001

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 255002    Accepted Submission(s): 63139


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
  
  
1 100
 

Sample Output
  
  
1 5050
 

Author
DOOM III
 

Recommend
We have carefully selected several similar problems for you:   1090  1003  1091  1004  1092 
 

Statistic |  Submit |  Discuss |  Note

/*
	Name: HDU 1001
	Copyright: Analyst 
	Author: Analyst 
	Date: 04/03/14 11:28
	Description: dev-cpp 5.5.3
*/
#include <stdio.h>

int main()
{
	int num, sum, i; 
	
	while (scanf("%d",&num) != EOF)
	{
		sum = 0;
		for (i = 1; i <= num; ++i)
			sum += i;
		printf("%d\n\n",sum);
	}
	
	return 0;
}

102148382014-03-04 16:10:47Accepted10010MS228K317 BCAnalyst


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值