Cube painting

 Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

picture21

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a b, r, or g. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

tex2html_wrap138tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE
本题的意思就是说,有三种颜色去涂到正方体上去,但是,你也知道正方体是可以旋转的,所以,让你设计个程序去判断上色方案是否相同。我一开始
的想法是通过旋转来判断是不是相同的,但是,由于代码实现的的比较冗长所以放弃了,后来,花了好几个正方体,才想到,其实三个面就可以确定一个正方体,所以,由此我先数组模拟下标代表了所有和1,2,3三个面等同的三个面(看不懂,看代码),然后和一个标准去对比,并且注意6-下标=它的反面!(由于数组的开始是0,所以在代码实现的时候是5-下标);
一开始错了好几遍,原来是吧TURE拼错了....
#include<stdio.h>
#include<string.h>
int a[24]= {1,1,1,1,2,2,2,2,3,3,3,3,4,4,4,4,5,5,5,5,6,6,6,6};
int b[24]= {2,4,5,3,6,4,1,3,2,1,5,6,2,6,5,1,1,4,6,3,5,4,2,3};
int c[24]= {3,2,4,5,3,6,4,1,6,2,1,5,1,2,6,5,3,1,4,6,3,5,4,2};
char str[20];
int main()
{
    int i;
    while(scanf("%s",str)!=EOF)
    {
        int flag=0;
        for(i=0; i<24; i++)
        {
            if(str[a[i]-1]==str[6]&&str[6-a[i]]==str[11])
            {
                if(str[b[i]-1]==str[7]&&str[6-b[i]]==str[10])
                {
                    if(str[c[i]-1]==str[8]&&str[6-c[i]]==str[9])
                    {
                        flag=1;
                        break;
                    }
                }
            }
        }
        if(flag)
            printf("TRUE\n");
        else
            printf("FALSE\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值