uva 10115 automatic editing

Problem E: Automatic Editing

Source file:autoedit.{c, cpp,java, pas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script.For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text,based on a fixed set of rules. Each rule specifies the string to find,and the string to replace it with, as shown below.

RuleFindReplace-by
1.ban bab
2.baba be
3.ana any
4.ba b hind the g

To perform the edits for a given line of text, start with the firstrule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text,and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you alwaysstart searching at the beginning of the text, (2) once you havefinished using a rule (because the find string no longer occurs)you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrencesof a find string are underlined and replacements are boldfaced.Note that rule 1 was used twice, then rule 2 was used once, thenrule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
banana boat babana boat
babana boat bababa boat
bababa boat beba boat
beba boat behind the goat

The input contains one or more test cases, followed by a linecontaining only 0 (zero) that signals the end of the file. Each testcase begins with a line containing the number of rules, whichwill be between 1 and 10. Each rule is specified by a pair of lines, where the first lineis the find string and the second line is the replace-bystring. Following all the rules is a line containing the text to edit.For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicatedin the input file by an empty line). During the edit process thetext may grow as large as 255 characters, but the final output textwill be less than 80 characters long.

The first test case in the sample input below corresponds to the exampleshown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output

          

behind the goat
shoe or shop


             题意分析:先输入两个字符串,C1,C2,再输入一个字符串C3(如果有多个替换规则则输入多个)。如果在字符串C3中出现C1,就把C1用C2替换。然后不停查找,有符合要求的就不停替换,直到C3中不再出现可以出现可替代的字符串为止。

       注意: 正确定义字符串数组。

       代码

#include<stdio.h>
#include<string.h>

int main()
{
	char *mark;
	char rep[260][100],str[500],temp[260][100];
	char c[500];//不能定义为char [500][500];
	int n,num;
	while (scanf("%d",&n) && n ){
		getchar();
		memset(rep,0,sizeof(rep));
		memset(str,0,sizeof(str));
		memset(temp,0,sizeof(temp));

		for (int i = 0; i < n; i++){
			gets(temp[i]);
			gets(rep[i]);
		}
		gets(str);
		for (int i = 0; i < n; i++){
			while(1){
				mark  = strstr(str,temp[i]);
				if (mark == NULL)
					break;
				sprintf(c, "%s", mark + strlen(temp[i]));
				sprintf(mark, "%s", rep[i]);
				sprintf(mark+strlen(rep[i]), "%s", c);
		} 
		}
		printf("%s\n",str);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值