搜索(dfs)



The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 
 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
 

Sample Input

    
    
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output

    
    
NO YES
 对于dfs和bfs的应用,主要表现在对图的搜索上;
对于本题,和上个bfs相似:方向,起点,终点;
但是这个题有些剪枝:
1.奇偶剪枝:
记住这个定理:
所有路径-最短路径的差必定为偶数;
2.步数与时间的关系;
若最短步数>时间肯定不符合;

#include<stdio.h>
#include<math.h>
#include<string.h>
int state[10][10],time,a,b,rx,ry,ax,ay;
char map[10][10];
int num[4][2]={{0,1},{0,-1},{1,0},{-1,0}},flag;
void DFS(int x,int y,int step)
{
    int i,kx,ky;
    if(x==ax&&y==ay)
    {
        if(step==time)
        flag=1;
        return;
    }
    if(step==time)return;
    if(map[x][y]=='X')return;
    if(flag)return;
    for(i=0;i<4;i++)
    {
        kx=x+num[i][0];
        ky=y+num[i][1];
        if(kx<0||kx>=a||ky<0||ky>=b)continue;
        if(state[kx][ky]==0)
        {
            state[kx][ky]=1;
            DFS(kx,ky,step+1);
            state[kx][ky]=0;
            if(flag)return;
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d%d%*c",&a,&b,&time)!=EOF)
    {
    	if(a==0&&b==0&&time==0)break;
        memset(state,0,sizeof(state));
        for(i=0;i<a;i++)
        {
            
            for(j=0;j<b;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='S'){rx=i;ry=j;}
                if(map[i][j]=='D'){ax=i;ay=j;}
            }
            getchar();
        }
        if(fabs(rx-ax)+fabs(ry-ay)>time||( rx + ry + ax + ay +time )%2==1){printf("NO\n");continue;}
        flag=0;
        state[rx][ry]=1;
        DFS(rx,ry,0);
        state[rx][ry]=0;
        if(flag)
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
    } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是一个使用matlab深度优先搜索DFS输出有向图环路的路径的示例代码: ```matlab % 定义有向图的邻接矩阵 adjMat = [0 1 0 0 0; 0 0 1 0 0; 0 0 0 1 0; 0 0 0 0 1; 1 0 0 0 0]; % 定义起始节点和终止节点 startNode = 1; endNode = 5; % 进行深度优先搜索 visited = zeros(1, size(adjMat, 1)); path = []; hasCycle = dfs(adjMat, visited, startNode, endNode, path); % 输出结果 if hasCycle fprintf('有向图存在环路,路径为:\n'); disp(path); else fprintf('有向图不存在环路。\n'); end % 定义深度优先搜索函数 function hasCycle = dfs(adjMat, visited, curNode, endNode, path) visited(curNode) = 1; path = [path, curNode]; hasCycle = false; for i = 1:size(adjMat, 1) if adjMat(curNode, i) == 1 if i == endNode path = [path, i]; hasCycle = true; return; elseif visited(i) == 0 [hasCycle, path] = dfs(adjMat, visited, i, endNode, path); if hasCycle return; end end end end visited(curNode) = 0; path(end) = []; end ``` 在该示例代码中,我们首先定义了一个有向图的邻接矩阵,然后定义了起始节点和终止节点。接着,我们调用了dfs函数进行深度优先搜索,并将visited数组用于记录每个节点是否已经被访问过,path数组用于记录当前搜索路径,hasCycle变量用于记录是否存在环路。最后,我们根据hasCycle变量的值输出结果。 在dfs函数中,我们首先将当前节点标记为已访问,并将该节点添加到当前搜索路径中。然后,我们遍历该节点的所有邻居节点,并依次进行以下操作: 1. 如果该邻居节点为终止节点,说明找到了一条环路,将该节点添加到当前搜索路径中,设置hasCycle为true,并返回; 2. 如果该邻居节点未被访问过,则递归调用dfs函数,并将返回值赋给hasCycle变量。如果hasCycle为true,则说明找到了一条环路,直接返回; 3. 如果该邻居节点已经被访问过,则跳过该节点继续遍历其他邻居节点。 最后,我们在dfs函数的末尾将当前节点标记为未访问过,并将其从当前搜索路径中移除,以便接下来的搜索

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值