Ubiquitous Religions
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 25556 | Accepted: 12619 |
Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9 1 2 1 3 1 4 1 5 1 6 1 7 1 8 1 9 1 10 10 4 2 3 4 5 4 8 5 8 0 0
Sample Output
Case 1: 1 Case 2: 7
Hint
Huge input, scanf is recommended.
我看计划的时候它是说分治,不过我一看这就是用并查集搞啊,我在怀疑是不是计划上的分类弄错了,然后我去网上看看博客,大家都是用并查集做的,也没有什么分治啊~
知道用并查集,思路就很简单了:初始化f[]数组,如果两个人信仰的宗教一样就把他们合并,最后遍历f[]数组看看还有几个没合并的就是答案。(不过这里到最后也可以不用遍历f[]数组,可以在每合并一次,总学生数就n--,最后的n就是答案了,这样应该可能会快一点吧~)
还有就是我这里把m定义成了64位的,怕溢出,不知道这里会不会爆int,没试,大家如果知道的话可以给我评论说一下,谢谢啦~^_^
#include <stdio.h>
#include <string.h>
#include <math.h>
#define MAX 50000
typedef long long ll;
struct UFSet
{
int f[MAX+2];
int i;
void init(int n){
for(i=0;i<=n;i++)
f[i]=i;
}
int find(int x){return f[x]==x?x:f[x]=find(f[x]);}
void Union(int x,int y){
if((x=find(x))==(y=find(y))) return ;
f[y]=x;
}
}S;
int main()
{
int i,j,n,res,cas=1;
ll m;
int a,b;
while(scanf("%d%lld",&n,&m)!=EOF)
{
if(n==0 && m==0)
break;
S.init(n);
res=0;
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
S.Union(a,b);
}
for(i=1;i<=n;i++)
if(S.f[i]==i)
res++;
printf("Case %d: %d\n",cas++,res);
}
return 0;
}