POJ 3663 Costume Party (二分查找)

这篇博客介绍了如何利用二分查找算法解决POJ 3663 Costume Party的问题。内容涉及在万圣节期间,农夫约翰需要将他的奶牛们带到化妆舞会,但只有一个适合长度为S的服装。约翰有N头奶牛,每头奶牛的长度不等。问题在于找出多少对不同的奶牛可以穿上这件服装,条件是它们的长度之和不超过服装的长度S。输入包含N头奶牛的长度,输出是满足条件的奶牛对数,注意奶牛的顺序不影响结果。
摘要由CSDN通过智能技术生成
Costume Party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12297 Accepted: 4891

Description

It's Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length of (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1..N; cow i has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input

* Line 1: Two space-separated integers: N and S
* Lines 2..N+1: Line i+1 contains a single integer: Li

Output

* Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input

4 6
3
5
2
1

Sample Output

4
给一个序列,取两个数之和小于等于K,问这样的组合有多少个。

二分查找。
先将序列排序,然后对于每个数a,二分查找有多少个数b,使a+b<=k,即二分求上限和下限,因为要去重,每次只需要从a后面的数到序列最后二分。

#include <stdio.h>
#include <algorithm>
using namespace std;
typedef __int64 ll;

const int maxn=20000+10;
int a[maxn];


int main()
{
	int n,s,i,j,t;
	ll ans;
	scanf("%d%d",&n,&s);
	for(i=0;i<n;i++)
		scanf("%d",&a[i]);
	sort(a,a+n);
	ans=0;
	for(i=0;i<n;i++){
		t=upper_bound(a+i+1,a+n,s-a[i])-(a+i+1);	//从i+1开始,这样不会有重复的情况
		ans+=t;
	}
	printf("%I64d\n",ans);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值