N - If We Were a Child Again 大数整除大数取余

Problem C
If We Were a Child Again

Input: standard input
Output: standard output

Time Limit: 7 seconds

 

“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

 

 

The Problem

 

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

 

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

 

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

 

 
Output

A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

 

 
 
Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

 
 
Sample Output

1

9

1

2147483646

这道题从周一开始做到今天上午才刚刚AC 先是各种OLE 再是各种RE 然后一个WA 一个TLE  现在终于对了 心里有点小激动

一开始的错误主要就是算法上有点小问题 所以不管数组定义的多大都是一直在RE 后来改了算法取余方面想的太麻烦了 所以又出了点问题



#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
struct bign
{
    int len;
    int s[1000];
};
bign a,res;
char str[1000];
long num;
int main()
{
    void change(bign *a);
    void div();
    long mod();
    char c;
    while(scanf("%s %c %ld",str,&c,&num)!=EOF)//因为分子无限大 所以用字符串来保存
    {
        change(&a);
        if(c=='/')
        {
            int i=0,j;
            div();
            while(i<res.len-1&&res.s[i]==0)
                ++i;
            for(j=i; j<res.len; j++)
            {
                printf("%d",res.s[j]);
            }
            printf("\n");
        }
        else if(c=='%')
        {
            long ans;
            ans=mod();
            printf("%ld\n",ans);
        }
    }
    return 0;
}
void change(bign *a)//将字符串中的整数挨个拿出来
{
    int i;
    a->len=strlen(str);
    for(i=0; i<a->len; i++)
        a->s[i]=str[i]-'0';
}
void div()//运算整除
{
    int i,j=0;
    long sum=0;
    for(i=0; i<a.len; i++)
    {
        sum=sum*10+a.s[i];
        res.s[j]=sum/num;
        sum=sum%num;
        j++;
    }
    (&res)->len=j;
}
long mod()//运算取余
{
    int i,j;
    long ans=0;
    for(i=0; i<a.len; i++)
    {
        ans=ans*10+a.s[i];
        ans=ans%num;//直接对从前到后每一位取余 没有运用那个什么什么法则
    }
    return ans;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值