Poj 1442 Black Box(优先队列水题)

该博客介绍了如何利用优先队列解决Poj 1442问题,即在给定序列中按指定位置插入元素,并在每次插入后输出当前最小元素的过程。此题被视为一道简单的数据结构应用题。
摘要由CSDN通过智能技术生成

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8070 Accepted: 3309

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2


题意:
给定一个序列,每次插入序列中的一个数,给定另一个序列,表示在插入第几个数的时候取数,第一次取最小的,第二次取第二小的,依次,每次取数就将取出的数输出。


用优先队列,水题不解释;

#include<cstdio>
#include<queue>
#include<functional>
#include<vector>
using namespace std;
int A[30000];
int main(){
      priority_queue<int,vector<int>,greater<int> > q1;
      priority_queue<int,vector<int>,less<int> > q2;
      int m,n,c=0,t,u;
      scanf("%d%d",&m,&n);
      for(int i=0;i<m;i++)scanf("%d",&A[i]);
      for(int i=0;i<n;i++){

            scanf("%d",&u);
            while(c<u){
                  q1.push(A[c]);
                  if(!q2.empty()&&q1.top()<q2.top()){
                        t=q1.top();
                        q1.pop();
                        q1.push(q2.top());
                        q2.pop();
                        q2.push(t);
                  }
                  c++;
            }
            printf("%d\n",q1.top());
            q2.push(q1.top());
            q1.pop();
      }
      return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值