Poj 1129 Channel Allocation(Dfs剪枝)

10 篇文章 0 订阅



Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12748 Accepted: 6533

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

题意:

当一个广播电台在一个非常大的地区,广播站会用中继器来转播信号以使得每一个接收器都能接收到一个强烈的信号。然而,每个中继器必须慎重选择使用,使相邻的中继器不互相干扰。如果相邻的中继器使用不同的频道,那么就不会相互干扰。

由于无线电频道是一有限的,一个给定的网络所需的中继频道数目应减至最低。编写一个程序,读取一个中继网络,然后求出需要的最低的不同频道数。


简单的填色搜索,剪枝方法就是利用组合数学中的四色定理;

四色定理又称四色猜想、四色问题,是世界三大数学猜想之一。四色定理是一个著名的数学定理,通俗的说法是:每个平面地图都可以只用四种颜色来染色,而且没有两个邻接的区域颜色相同。1976年借助电子计算机证明了四色问题,问题也终于成为定理,这是第一个借助计算机证明的定理。(Ps;转自百度百科);

这里的邻接的区域指的是两块多边形地区“至少一条边重合”才称之为相邻;



#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

struct node{
    int v;
    int next;
}edge[3000];

int head[30];
int num;

int ans;
int n;
int vis[30];

int flag;
int col;

void add(int u,int v){
    edge[num].v=v;
    edge[num].next=head[u];
    head[u]=num++;
}

int ok(int num){//判定图是否可达
    for(int i=head[num];i!=-1;i=edge[i].next){
        int v=edge[i].v;
        //printf(" vis[%d] = %d  vis[%d] = %d \n",v,vis[v],num,vis[num]);
        if(vis[v]==vis[num])
            return 0;
    }
    return 1;
}

void Dfs(int u){
    if(u==n){
        flag=1;
        return ;
    }

    for(int i=1;i<=col;i++){//控制颜色数,使得col就是答案
        vis[u]=i;
        if( ok(u) )
            Dfs(u+1);
        vis[u]=0;
    }

}

int main(){
    char str[30];
    while(scanf("%d",&n)!=EOF){
        if(n==0)
            break;
        memset(head,-1,sizeof(head));
        num=0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++){
            scanf("%s",str);
            int u=str[0]-'A';
            int len=strlen(str);
            for(int j=2;j<len;j++){
                int v=str[j]-'A';
                add(u,v);
            }
        }

        /*for(int i=head[2];i!=-1;i=edge[i].next){
            cout<<edge[i].v<<endl;
        }*/

        flag=0;
        ans=0x3f3f3f3f;
        for(col=1;col<=4;col++){//四色定理剪枝
            Dfs(0);
            if(flag)
                break;
        }
        if(col==1)
            cout<<"1 channel needed."<<endl;
        else
            cout<<col<<" channels needed."<<endl;
    }

    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值