poj 3624 Charm Bracelet 背包

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

这个代码是开始写的后来发现数组太大导致错误开小了又满足不了条件

#include<stdio.h>
int c[3405][12888];
int knaspace(int m,int n)
{
    int w[5000],p[5000];
    int i,j;
    for(i=1; i<=n; i++)
        scanf("%d %d",&w[i],&p[i]);
    for(i=1; i<=n; i++)
        for(j=1; j<=m; j++)
            c[i][j]=0;
    for(i=1; i<=n; i++)
        for(j=1; j<=m; j++)
        {
            if(w[i]<=j)
            {
                if(p[i]+c[i-1][j-w[i]]>c[i-1][j])
                        c[i][j]=c[i-1][j-w[i]]+p[i];
                        else
                            c[i][j]=c[i-1][j];
                }
                        else c[i][j]=c[i-1][j];
        }
    return (c[n][m]);
}
int main()
{
    int m,n,s;
    scanf("%d %d",&n,&m);
    s=knaspace(m,n);
    printf("%d\n",s);
    return 0;
}
这个是改写后的一维数组
#include<stdio.h>
#define N 3405
#define M 12888
int c[N],w[N];
int f[M];
int max(int a,int b)
{
    if(a>=b)
        return a;
    else
        return b;
}
int main()
{
    int i,j,m,n;
    scanf("%d %d",&n,&m);
    for(i=1;i<=n;i++)
        scanf("%d %d",&c[i],&w[i]);
        for(j=0;j<=m;j++)
            f[j]=0;
    for(i=1;i<=n;i++)
        for(j=m;j>=c[i];j--)
    {
        f[j]=max(f[j],(f[j-c[i]]+w[i]));
    }
    printf("%d\n",f[m]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值