HDU 2602 Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”.
许多年前,在泰迪镇有这么一个骨骼收集家。

This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
这个人喜欢收集一些骨骼,比如:狗的、牛的、当然也有人骨……

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones ,
在他旅途中,他会带上一个体积V的大包,专门用来放置各种收集到的骨骼。

obviously , different bone has different value and different volume, now given the each bone’s value along his trip ,
众所周知,不同的骨骼有着不同的收集价值和体积,这一点在其旅途中我们预先给出。

can you calculate out the maximum of the total value the bone collector can get ?
请你计算出骨骼收集家利用他的包,旅途中收集到的最大总价值?

Input

The first line contain a integer T , the number of cases.
第1行包含1个整数T,表示测试数据的组数。

Followed by T cases , each case three lines ,接下来有T组测试数据,每组测试数据3行,
the first line contain two integer V, N, (V <= 1000 , N <= 1000 )representing the number of bones and the volume of his bag.

第1行包含两个整数V,N, (V <= 1000 , N <= 1000 ),其中:N表示骨骼的数量,V表示包的体积。
And the second line contain N integers representing the value of each bone.

第2行包含N个整数,依次代表N个骨骼每一个骨骼的体积。

第3行包含N个整数,依次代表N个骨骼每一个骨骼的价值。
The third line contain N integers representing the volume of each bone.



Output

One integer per line representing the maximum of the total value (this number will be less than 2^31).
输出一个整数,占一行,表示总价值。(<2^31)


原文::
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
#include<stdio.h>
#define MANH 1010
int Max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int v,n,w[MANH],f[MANH],i,j,t,h[MANH];
    scanf("%d",&t);
    while(t--)
    {
        memset(f,0,sizeof(f));
        scanf("%d %d",&n,&v);
        for(i=1; i<=n; i++)
            scanf("%d",&h[i]);
        for(i=1; i<=n; i++)
            scanf("%d",&w[i]);
        for(i=1; i<=n; i++)
            for(j=v; j>=w[i]; j--)
            {
                f[j]=Max(f[j],(f[j-w[i]]+h[i]));
            }
        printf("%d\n",f[v]);
    }
    return 0;
}
开始没清空数组错误
后来结果没带换行符好错误
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值