hdu 1142 A Walk Through the Forest 最短路

题意:看样子很多人都把这题目看错了,以为是求最短路的条数。真正的意思是:假设 A 和 B 是相连的,当前在 A 处,如果 A 到终点的距离大于 B 到终点的距离,
则可以从 A 通往 B 处,问满足这种的条件的路径条数。
分析:1、以终点 2 为起点 dijkstra;

2、直接DFS记忆化搜索。

Description

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647 
 

Sample Input

       
       
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output

       
       
2 4
 
现在才知道原来dis求出来的就是每个点到要求点得最短距离
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int map[1005][1005],dis[1005],vis[1005],dp[1005];
int n,m;
void prim()
{
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=n; i++)
        dis[i]=map[2][i];
        dis[2]=0;//以前没注意到这错了好多遍
    vis[2]=1;
    for(int i=1; i<=n; i++)
    {
        int minl=INF,pos;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&minl>dis[j])
            {
                minl=dis[j];
                pos=j;
            }
        }
        if(minl==INF)
            break;
        vis[pos]=1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>dis[pos]+map[pos][j])
                dis[j]=dis[pos]+map[pos][j];
        }
    }
}
int DFS(int v)
{
    int sum=0;
    if(dp[v]!=-1)
    return dp[v];
    if(v==2)
    return 1;
    for(int i=1;i<=n;i++)
    {
        if(map[v][i]!=INF&&dis[v]>dis[i])
        sum+=DFS(i);
    }
    dp[v]=sum;
    return dp[v];
}
int main()
{

    int u,v,w;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        memset(map,INF,sizeof(map));
        for(int i=1;i<=n;i++)
            dp[i]=-1;
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            if(map[u][v]>w)
            {
                map[u][v]=w;
                map[v][u]=w;
            }
        }
        prim();
        printf("%d\n",DFS(1));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值